Flask-SQLAlchemy

_images/flask-sqlalchemy-title.png

Flask-SQLAlchemy is an extension for Flask that adds support for SQLAlchemy to your application. It aims to simplify using SQLAlchemy with Flask by providing useful defaults and extra helpers that make it easier to accomplish common tasks.

See the SQLAlchemy documentation to learn how to work with the ORM in depth. The following documentation is a brief overview of the most common tasks, as well as the features specific to Flask-SQLAlchemy.

Requirements

Our Version

Python

Flask

SQLAlchemy

2.x

2.7, 3.4+

0.12+

0.8+ or 1.0.10+ w/ Python 3.7

3.0+ (in dev)

2.7, 3.5+

1.0+

1.0+